This is a public Forum  publicRSS

Topic

    Mike Spreitzer
    Standard user can not scan in PaperPort Pro 14
    Topic posted September 11, 2012 by Mike Spreitzer, tagged Installation and Configuration Topics, Troubleshooting 
    5357 Views, 22 Comments
    Title:
    Standard user can not scan in PaperPort Pro 14
    Content:

    I have PaperPort Pro 14 installed on my Windows 7 (32 bit) desktop computer and an Epson WorkForce 610 multifunction device (printer, scanner, FAX, copier) out on my LAN.  I installed the latest Epson driver & utilities package for that printer and OS on that desktop machine.  When I log into the desktop as an Administrator, everything works great.  When I log in as a standard user, everything except scanning from Nuance works.  I tested the Epson Scan application from Epson, and I tested scanning from OpenOffice.org 3.4.1; those work.  In PaperPort, when I select the "Scan Settings" tab under the Desktop menu, the "Scan" button stays grayed out.  Even if I click on "Select..." and pick "TWAIN: EPSON WorkForce 610" (the only choice) and click "OK" (as opposed to "Cancel" or "Advanced setup"), and then OK to the confirmation window, the "Scan" button stays grayed out.

    If I (as a standard user) pick "Advanced setup" instead of "OK" in the "Select..." dialog, the pop-up window goes away and nothing more visible happens.

    If, while logged in as a standard user, I run PaperPort "as an administrator", then scanning setup and usage works fine.

    Running the `sfc` command in a command window as an administrator finds nothing.

    Comment

    • Michael Kenward

      I am not really sure that I can unravel what is going on in this long-paragraph free message. So what follows is probably something that you have done already.

      Working on a similar problem with someone else, it turned out that they had not run the scanner setup regime in PaperPort itself.

      This meant that the scanner worked OK in other things, but PaperPort did not know what to do with it.

      Is that the essence of what you are saying here?

      Of so, you could try running the Scanner Wizard as a standalone program. You will find it on your PC here:

      C:\Program Files (x86)\Nuance\PaperPort\ScannerWizardU.exe

      Or, maybe here:

      C:\Program Files\Nuance\PaperPort\ScannerWizardU.exe

      If that doesn't work, have you tried scanning in a different User account?

      I do hope you have not done something strange like turning off "User Access Control" in Windows. People do that because they think they know better than Microsoft. In reality it is a great way to cause problems.

       

      • Mike Spreitzer

        The essence of my complaint is that while logged in as a Standard User I can use my scanner from other programs (I listed the two I tested) but not PaperPort.  Following are the details, with more white space, and then responses to your suggestions.

        While logged in as an administrator, I installed the Epson software for my WF610 from the install disk, then I installed PaperPort, then I installed the available update to PaperPort.  I was able to do everything expected from every program, including scanning from within PaperPort and within the Epson Scan program.

        Later I created a Standard User, and then logged in as that Standard User.  When I tried to use the scanner I had several problems.  After trying several unsuccessful resolutions, I noticed that Epson offers a newer download of everything.  So I logged out of the Standard User account, logged in as an administrator, uninstalled all the Epson software (with the necessary reboots, and another one at the end), then downloaded and installed the latest Drivers & Utilities combo from Epson for using a network-attached WF610.

        Testing again, I found that everything worked as expected when logged in as an administrator.  I also tested again while logged in as a Standard User, and in this case I got good results from everything except PaperPort.  I also found that while logged in a Standard User, if I launch PaperPort in the "run as administrator" way then scanning works.  I think this combination of tests puts suspicion primarily on PaperPort.

        I tried the standalone scanner config wizard that comes with PaperPort, and it did not solve my problem.  I do not have access to the problem system right now, I will have to double-check and post details later.  But I am aware that PaperPort requires some setup, and I tried every alternative I could think of.  I even tried running the standalone setup wizard "as an administrator" and then launching PaperPort in the regular way (during the same Standard User login); this, too, left me unable to scan from within PaperPort.

        I have not turned off User Acess Controls in Windows.

        Thanks for any further ideas!

    • Michael Kenward

      Did you try running the Scanner Wizard as a standalone program.

      C:\Program Files (x86)\Nuance\PaperPort\ScannerWizardU.exe

      Or, maybe here:

      C:\Program Files\Nuance\PaperPort\ScannerWizardU.exe

      Is that what you mean by the "standalone scanner config wizard that comes with PaperPort"? (There are several ways of testing a scanner in PaperPort.)

      If so, that is an important piece of information missing from your first post.

      This wizard was the solution to the only other report I have seen of this phenomenon.

      You seem to have done a lot of other things that you also did not mention in your first post – all that stuff about updating the Epson software – so you might find it useful to run a "Repair" on your installation of PaperPort. This would fix anything that may have got broke during your Epson updates.

       

    • Mike Spreitzer

      The standalone scanner thing from Nuance that I tried is something I found under the Start button, in the Nuance PaperPort 14 section, in there it is known as "Scanner Setup Wizard".  This is a shortcut whose target is

      "C:\Program Files\Nuance\PaperPort\ScannerWizardU.exe" /A [PaperPort 14.0] /L [eng]

      If I right-click on that shortcut and pick "Run as administrator" from the popup, it successfully launches the wizard: I get a window titled "Select Scanner", with TWAIN among the checked boxes at the top, and "TWAIN: EPSON WorkForce 610" highlighted in the list section; clicking on "OK" dismisses the window without complaint.

      If instead I run that same shortcut in the regular way (not "Run as administrator"), I do not get the "Select Scanner" window.  Instead I get a little window whose title is "Nuance Scanner Setup Wizard" and whose content is an error message --- (white cross inside red circle) "File not found" --- and an "OK" (as if!) button.

    • Mike Spreitzer

      BTW, should I expect the Repair operation (associated with "Nuance PaperPort 14" (remember that I have the Pro version) in the Programs and Features section of the control panel) to work even though I have installed the patch (PP14PRO_E_Patch1.exe from Nuance)?  I am worried because I started it (Repair) and it asked me to insert the original install disk, leaving me to wonder if it is going to undo part of the patch.

    • Mike Spreitzer

      Not being sure whether or how to proceed with Repair, I decided instead to dig deeper.

      So I uninstalled everything whose name started with "Epson", "Nuance", or "PaperPort" (thus covering both the Epson WorkForce 610 and Nuance PaperPort Pro 14), with all the attendant restarts plus one more at the end for good measure.

      Then I reinstalled the WF610 software (as administrator) and tested (logged in as administrator, then logged in as standard user).  The Epson scanning software worked in both cases.

      Then I logged in as administrator and re-installed PaperPort Pro 14, and then the two patches for it.  Testing while logged in as administrator, I got good results in all cases.

      Then I logged in as a standard user and tested again, and I got the same old behavior: Epson scanning software works, scanning into OpenOffice works, scanning with Nuance software fails in the ways reported above.  The Nuance Scanner [Setup] Wizard complains about "File not found".

    • Mike Spreitzer

      On September 12 I asked Nuance support about this problem.  They took a long time to get back to me, and eventually decided that I should expect nothing more than the behavior I observe.  The last response from them says

      In the first place PaperPort requires Administrator Rights.

      I find that hard to believe.  Is anybody else on this forum succeeding with scanning while logged in as a Standard User?

      Thanks!

      • Michael Kenward

        Is anybody else on this forum succeeding with scanning while logged in as a Standard User?

        Not here. I allow "Admin" rights.

        That you get the thing to work when you "Run as Administrator" suggests that Support is correct in saying that Users need Administrator rights.

        I always grant Admin rights to users, but that is because I am the only user.

        Is there any reason why you are reluctant to grant Admin rights?

        It does, though, seem like a mistake on Nuance's part to design software that insists on Admin rights, especially when other software can happily get at the scanner.

        One final thought, in Standard Users, have you tried changing the "Compatibility" settings for PaprPort.exe to "Run this program as an administrator"?

         

        • Mike Spreitzer

          I am reluctant to grant Admin rights to the standard users because they are prone to getting infected by malware; I do not want to make the malware's life any easier than necessary.  I have twice had the semi-good fortune to fight off something that infected just one Standard User.

          Yes, I tried setting "run as administrator" in the compatability settings (I tried it "for all users" and whatever you call the smaller scope case).  This causes Windows to insist that the Standard User type an administrator password --- which is also a security problem.

    • Michael Kenward

      It does seems nuts to have to go through these hoops to get people to use what should be standard features. I can't believe that Nuance does not have corporate customers who, like you, sensibly want to protect users and systems from themselves and the nasties out in the world.

      Coincidentally, here is another comment on similar lines to those that I made:

      PaperPort 14 does not print to pdf . Archive (59) . PaperPort . Forum . Nuance Forums

      Charles knows his onions. It might add another wrinkle to my suggestion.

       

    • James Gammon

      I am having the same problem as Mike....namely, Paperport 14 Pro was installed under Administrator in Windows 7 Pro

      but will not allow standard users to scan in Paperport.  This needs to be fixed or a work around posted / explained.  Otherwise,

      the Administrator can not delegate use (scanning) to lower level workers with out granting them full Administrator rights.

      Additionally, when using Paperport in health care related applications, giving everyone Administrator rights in order to use

      the program may not meet the HIPPA laws / rules / regulations ??    Hopefully, someone will post a solution for this problem.

      Thanks.

    • Mike Spreitzer

      James, for me the critical issue is not whether the user is Standard.  I found that if I create another administrator account, it cannot scan either.  Is it this way for you too?

      • James Gammon

        Mike,

        I did not attempt to create a second administrator account...just defaulted using Paperport by giving my Staff scanner

        password for full Administrator rights.  Of course this means she must log off her standard (Non Administrator log on) and

        log back in as under Administrator (with full rights as Administrator).  Obviously this is not ideal and need to be fixed but I

        do not know how to fix this problem.  Perhaps Nuance can offer some suggestions or upgrade fix ????

    • Alex Han

      I know this post is rather old, but since no one posted a solution. I thought I may give it a go. Hopefully this helps someone.     

      This is the machine I was working on:
      -Paperport 14
      -WIndows 7 Professional 64bit
      -Domain User
      -Local Administrator Account enabled
      -My Documents mapped to another location (Example V:)

      First off it didn't matter whether the domain user had "administrator" or "user" privileges, since whoever had installed Paperport in the first place will be able to scan. I tried granting my domain user "administrator" privileges but it still wouldn't allow me to scan since it was installed on the local administrator profile. So to work around this, I uninstalled Paperport. Gave my domain user "administrator" rights (Start->Right click Computer->Manage->Local Users and Groups->Groups->Right click Administrators->Click Add to group->Click Add) and then proceeded to install Paperport on the domain login. When it checked out that it worked. I logged back in as the local administrator, I changed the rights to the domain user back to "user", and then voila it worked.

      This may not apply to everyone, but I did run into a problem however. I received an Error 1327: Invalid Drive while trying to install it. This was due to having our users "My Documents" stored on a file server. To remedy this you will have to either change the location of the My Documents or use Regedit to go to HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/User Shell Folders and **/Shell Folders

      Change Personal to C:\My Documents

      You can change it back after the installation.

      Good Luck hopefully this helps someone

    • Mike Spreitzer

      Thanks, Alex, for trying --- but that does not help me.  I am trying to maintain security, which means I *never* give administrative privileges to a standard user.  I do not even tell them any administrator password.

      • Alex Han

        Yes understandable. This is why you only temporarily give them Administrator rights, Install Paperport, and then switch it back to User rights. Paperport should still be functioning even when they're a user.

    • Mike Spreitzer

      For me, "temporarily" is inconsistent with "never".

    • Michael Kenward

      As I understand it, probably wrongly, Alex suggests a one-off event. Do not give anyone temporary access. Do it yourself.

      It will achieve the desired effect with no chance of compromising your security.

      Of course, this won't work if you can do the job yourself.

       

       

       

       

    • Mike Spreitzer

      Unfortunately, in Windows, things get "installed" in each user's account.  Sometimes bad things, without anybody noticing it.  Even if a fully trustworthy person logs into a standard user account, this can run malware that was installed in that user's account earlier.

    • Mike Spreitzer

      Twice on Windows computers I have had the experience of discovering an infection that was not detected by the protection software such as Norton Internet Security and MalwareBytes Anti-Malware.  Fortunately, those infections were confined to a single standard user account.