This is a public Forum  publicRSS

Topic

    Todd Solomon
    Registry settings are corrupt message on install of 11.5 - a...
    Topic posted July 1, 2012 by Todd Solomon  , tagged Installation and Configuration Topics, Troubleshooting
    3407 Views, 18 Comments
    Title:
    Registry settings are corrupt message on install of 11.5 - a long, trying process.
    Content:

    Hello everyone,

    I have had a serious issue trying to get Dragon 11.5 to work. I have had literally months of conversations with support, who frankly seem clueless and kept sending the same scripted responses time after time and didn't respond for weeks at a time. I'm now in the process of getting a refund-also nigh on impossible to do-BUT if I can get a fix from the user community, I'll be happy. I'd rather have it working then a refund. I've been using Dragon since v3.5 and have been a loyal and happy user up to now.

    I'm running Vista 32 bit, all updates installed.

    I've been asked to try:

    using the remover tool and reinstalling,

    running the repair option for the installation,

    run from the command prompt "C:\Program Files\Nuance\NaturallySpeaking11\Program\natspeak.exe" /fixguids,

    and lastly, uninstall then remove all registry entries by hand, and reinstall

    the original support email I sent, describing the problem:

    Hi, just purchased and installed 11.5 and it will not load. When loading the following error is received. I have tried running the repair option with the same result, it will not load.
    Please advise.
    Message:
    One or more registry settings are corrupt and your registry permissions prevent Dragon NaturallySpeaking from correcting them. Please run Dragon NaturallySpeaking Setup and select the Repair option.

    After months of back and forth with support, this is the last one I sent before starting the refund process:

    Hello.
    In a last ditch attempt to finally fix Dragon today I did the following:
    -I uninstalled it using the control panel.
    -Then, for good measure, I ran the Dragon 11 remover tool to ensure I had thoroughly uninstalled, and restarted my computer.
    -I then installed Dragon 11. When I attempted to run the installed program, I received the same error message as always "One or more registry settings are corrupt and your registry permissions prevent Dragon NaturallySpeaking from correcting them. Please run Dragon NaturallySpeaking Setup and select the Repair option."
    -I went over every direction I have been given to fix the problem and tried them all again, paying careful attention to detail.

    I still can not use Dragon 11. You have no idea how much I want to use this, but unless you have another solution this is a dud. Please advise on how I can obtain a refund, thanks.

     -------

    Fellow users, does anyone have any ideas? I'm stumped and frustrated. Thanks!

    Comment

     

    • Show/Hide RepliesAnonymousposted July 1, 2012
      This has been removed by a moderator
      • Todd Solomon

        Thanks. I tried CCleaner, and I like it.

        As for dragon 11.5, I reinstalled it after the cleaning and for the first time ever received a new error message, it now says 'The file DOCOBJ.DLL did not register itself.'

        I can't get past this, unfortunatley, even with the Lindsays suggestions.

    • Lindsay Adam

       Can you try the following, (attempt to load DNS after each numbered step below), and tell me what the results are:

      1. Turn off UAC (Control Panel | User Accounts | Change User Account Control settings | set to "Never Notify" and reload Windows

      if no change then try… (Leave UAC set to never notify)

      2. Use Windows Explorer and go to:

      C:\Program Files (x86)\Nuance\NaturallySpeaking11\Program\natspeak(.exe)

      Right click on that file and "Run as Administrator"

      If no change then try…

      3. Right click on the file in 2 above and then click on Properties | Compatibility and run in windows XP service Pack 3 mode

      Although none of these steps may work to get it fully running please can you let me know what happens with each step if anything different. Also if none of these steps work can you answer the following questions:

      Are you logged in as an administrator?

      can you just confirm that the installation process goes okay and it is only when you try to run DNS that you get this error regarding the registry?

      If you go to Programs and Features in the Control Panel and list the programs installed (view them alphabetically). Can you tell me what it says for the Visual C++ Runtime for Dragon NaturallySpeaking and also if you have any other Visual C++ runtimes installed.

      Can you also attach your Dragon log to the forum:

      Start Menu | All Programs | Dragon NaturallySpeaking 11 | Show Dragon Log

      Lindsay
      www.pcbyvoice.com

      • Todd Solomon

        Thanks Lindsay.

        I reinstalled 11.5 since I had uninstalled it previously, and tried the CCleaner program advice from Marty Markoe. Interestingly, now I have a new error message "The file DOCOBJ.DLL did not register itself." First time anythigng has changed.

        I've tried your suggestions, but nothing has got me past this and there was no change at each step. Nuance has given me 3 more days to claim my refund, so if I can't find a fix by tomorrow ight then back it goes.

        To answer your questions-Adminstartor, yes. Installation goes fine, then the error(s) have always been on program start up.

        I have several Visual C runtimes showing, and Visual C++ 9.0 for Dragon Naturally Speaking is one of them.

        Log attached.

        Thanks! Todd

    • Lindsay Adam

      Well I wish I got to you before you used a registry cleaner but biting my tongue and avoiding the rant about registry cleaners and defragmentation tools I will try and be a bit more constructive. Besides you may consider this new error message as progress of some sort. Let's hope that more such messages don't appear running your other applications.

      You may want to look at the following link although I know nothing of its integrity and authenticity:

      http://www.almuseo.com/docobj-dll-windows-7-download.php

      You will also find lots of other stuff on Google regarding this error as well as a 20 year argument why you should or should not use registry cleaners and such tools. Basically they are just not necessary with Windows Vista and Windows 7 and cause more problems than they resolve, no disrespect to your suggestion Marty and that of course is my personal opinion on such tools having spent 25 years as a hardware engineer and software developer.

      Incidentally because you have run the registry cleaner the Dragon log tells me nothing other than you are running in compatibility mode and you have the error with the docobj.DLL.

      Lindsay
      www.pcbyvoice.com

      • Todd Solomon

        I had previously uninstalled Dragon as I was asking for a refund, and reinstalled after the cleaning. So the log is what it is I guess.

        No issues with any other programs after running the cleaner, and frankly I have no clue if it was good, bad, or whatever. But since it was recommended here and had a ton of good reviews (I did a thorough check, I'm a suspicious guy sometimes) I took the chance.

    • Show/Hide RepliesAnonymousposted July 5, 2012
      This has been removed by a moderator
    • Lindsay Adam

      We do not agree with Lindsay's comment that Windows 7 and Vista registry does not require cleaning. Every time you load a program, update a program, remove a program, add or remove hardware, registry entries are made and the Registry becomes bloated.

      That is the sort of nonsense that we get from from the vendors of these application, are you actually aware of how many programs you would need to install, uninstall, pieces of hardware, each and every day in order to actually seriously bloat your registry. For an average user registry bloating is a complete myth in terms of its slowing down your computer and in most cases these programs just give a placebo effect. Anyway don't take my arguments for it, just look at the problems all over Google caused by these programs and the serious studies done by various professionals looking at the pros and cons of such programs.

      Let's just agree to disagree.

      http://www.edbott.com/weblog/2005/04/why-i-dont-use-registry-cleaners/

      Lindsay
      www.PCByVoice.com

      • Rüdiger Wilke

        I think I'll never stop being amazed by people believing that anyone could take care of Microsoft better than Microsoft can for themselves, or that you need additional third-party applications on a larger scale in order to run a major software properly, or more specifically, that you need particular pieces of hardware in order to use speech recognition for instance. Just as if those companies themselves, such as Microsoft or Nuance, had no clue of what they're doing.

        Rüdiger



         

        • Anonymousposted July 5, 2012
          This has been removed by a moderator
    • Rüdiger Wilke

       

      Marty, 

      So here is my take on it. I will start by admitting that I haven't read the entire thread, and I'm not particularly commenting on the problem that Todd had and whether or not running the registry cleaner that you recommended has caused him any problems or not.

      I just came in when the question was raised whether running these kind of tools is necessary or even useful any longer on the most recent versions of the Windows operating system. I also have to admit that, for some period in time, I have actually been using the CC cleaner application in the past, but that was more than five years ago on an ancient, by current standards, system running Windows XP. I had done this following recommendations coming from certain sources spreading such, no need to mention who they were.

      During all this time, I really couldn't say for certain whether or not running the tool made any difference at all as regards to the proposed advantages you would expect that they provide. It is also true that it never caused any problem, therefore maybe so much for the placebo effect.

       At one point in time I stopped using it, just because having changed systems in between and failing to remember to reload it. One day, it occurred to me, but by then it was clear to me that I just didn't need it. Please also note that I am the type of user that likes to choose particularly which programs to install and run, and which not, and if I don't need them, I'd rather not have them.

      Now, as Lindsay has pointed out and given some reasonable resources of information to back up this point, with more recent versions of operating systems and software, these kinds of utilities seem to be fairly dated, if not even having a detrimental effect as opposed to doing what they are there for. So, in my experience, you don't really need them, and you're probably better off not using them from the start.

      As far as the references you are coming up with, sorry, but please don't bother to. That's just the typical sort of one advertiser quoting another of which the Internet has become bloated of recently to some extreme degree, and I have to say that this is something that really turns me off: being bugged by advertising of any kind all over the Internet!

      Rüdiger


    • Anonymousposted July 5, 2012
      This has been removed by a moderator
    • Rüdiger Wilke

      Marty,

      Yes I noticed that. Just another personal take on this: in many places, Wikipedia is any better than what I've mentioned. But once again, just my personal experience: for the past five years or so I haven't used any tune-up utilities whatever they are, and I consider myself a happy camper with computers.

      Rüdiger

    • Lindsay Adam

      Hardly credible sources of reference. CNET are the owners of download.com which is a download portal that make their money from providing downloads of such software which quite often include spyware/malware embedded within the applications.

      If I submitted a piece of academic work, for example, in University with a Wikipedia reference it would be thrown back in my face.

      Anyway none of this helps Todd use NaturallySpeaking, let us know how you get on trying the docobj.dll information on the link above and take it from there. If you want Todd I can do a remote connection and have a look, just email me on lindsay@pcbyvoice.com

      Lindsay

       

    • Todd Solomon

      Success! I've got the thing working. I'm writing this post using it. What a relief

      In the end it was Marty's suggestion that opened the doorway to finding a fix.

      Marty, Ccleaner was not the fix in and of itself. However once I ran that program, the error message I was receiving changed and I was able to troubleshoot the new message and find a fix. I have no idea what, exactly, happened to change the error message but that was the key to finding my solution. I have since 'torture tested' and reinstalled Dragon a couple of times, just to make sure the fix is stable (I was a bit paranoid after 6 months of banging my head against the Nuance wall.)

      Just so you know, the error message changed from the one I originally posted to the message "DOCOBJ.DLL failed to register" which was a relatively easy thing to troubleshoot

      I greatly appreciate everyone's willingness to help and should I ever have another problem I'll come here first. Frankly you are a great deal more able and willing to help and Nuance support itself.

      Todd

    • Anonymousposted July 8, 2012
      This has been removed by a moderator
    • Lindsay Adam

      Jeez guys we really can't see through this little sketch :-)

      Todd instead of quoting Marty's script would you be so kind as to enlighten other users what you actually did to fix the docobj.dll problem. After all the idea of the forum is to help and support DNS users and to that end such information may be useful for other users at some point. The more discerning users can then decide for themselves cause and effect.

      Lindsay